Adafruit Gemma M0 not recognised

Hi folks,
I just got one of the Adafruit Gemma M0 thingies. Cute little thing.
I have tried to plug it in to use with the Arduino IDE software. I followed the instructions on installing drivers etc (I have a windows 7 computer). When I plug the Gemma in it does not come up in any port lists. There is nothing in the Arduino IDE list, and in Device Manager it appears under “libusb-win32-devices” - USBtiny. Some assistance with this would be greatly appreciated.

Oh, Arduino IDE and USB ports work perfectly fine with connecting the Uno and Mega boards and I have tried a different cable.

Thanks folks

It should come up as a USB drive. I’m surprised it has come up as USBtiny.

Look carefully at it. Make sure it is not an older Adafruit Gemma with an ATtiny85.



Ok, so now I don’t know what to think or what to do…
It seems I have the older one…

I only just received it.

It’s an easy mistake to make anywhere in the supply chain, as the two products are very similar in appearance. Check your order and invoice. Contact your supplier directly using their feedback service. They’ll check their stock on the shelf, orders made, or other data to cross-check.

If it was Little Bird, read their Refund Policy, as it covers this well.

(For myself, given the price per unit, I’d just accept the mistake, order what I wanted, learn from it, and find another use for the older unit. It is still useful, just that you have to use a different programming method.)

:slight_smile: it was the Gemma starter pack, which is seems is the v2.

I have worked out that when I go to upload, I press the reset button when it is about to do the upload and it takes the upload. I just ignore the whole com port thing.

Yes, that will do it. Well done. I’ve a few of the v2, and although the attiny85 has limited features compared to the M0, it can work really well in some scenarios. I’ve used it with Arduino IDE, and with PlatformIO.