Arduino Advent Calendar Day 01 - Meet the Arduino

Need help for the Arduino Advent Calendar Day 1 Guide? Just post on this thread and our highly trained team of Arduino ninjas will be able to help you in no time!

Great idea for an advent calendar! Looking forward to it, but…

I’ve been unable to get the IDE to upload to the Arduino from my Windows 10 machine. It always throws a permission denied error on the COM port. Tried using a different COM port number within Device manager, but that makes no difference. The device is definitely on the port I think it is because I can see the state change when I plug/unplug it. Running as Admin made no difference. Fought with it for a while…

Then I moved to my Linux machine. Initially, I had the same problem (permission denied on the com port /dev/ttyACM0). Was finally able to get it to work using the solution posted here:

That’s all good since the linux box is my primary tinkering machine anyway, but curious what the trick is to get programming to work under Win 10.

Hi there,

For the Windows 10 issue, it might be that another device is hogging the port. Try unplugging other connected USB ports.

In Linux land, you need super user privileges to access the serial port.


Little known fact, Maddy founded (an electronics Q&A site) which was purchased by StackExchange and rebranded into , small world!



Thanks for the reply. Unplugging other USB devices (excpet mouse and KB) didn;t work. I had another crack at it today, and was eventually able to get it to work by using COM4 instead of COM3 (which was the default). I changed the Arduino port to COM4 in Advanced Port Settings in the Device Manager, then unplugged and replugged the board, and it worked.