BlueSMiRF Silver


Hi there,

I’ve purchased a few BlueSMiRF Silver devices to drive a few Arduinos for a project that I’m working on. I’ve read the documentation up on Sparkfun about the devices but I’m having trouble getting it to work. When I power up the devices the red status LED blinks about twice every second which indicates the configuration timer is still active. My understanding is that it should eventually start blinking more slowly. I’ve even tried resetting the device configuration.


I’ve a WRL-12577 here. The configuration timer length is also configurable, but the default ought to be a minute. I don’t have mine set to default any more, so I don’t know what the shipping default is, except by reference to the hookup guide. But check your power supply is clean and stable; the device could be restarting which would look a little like being stuck in “2 per second” mode. Tell us what you see when you try to configure the device over serial port?


Thanks @quozl, I’ll double check the power inputs to make sure that my solder job is good. It seems OK, but I’ll double check.


Thinking about it some more, there’s a regulator on the board that should clean up most power supply noise. If noise is coming in through another connection though, that could cause problems. (e.g. disconnect everything except power, see if the problem persists). Still, the best thing to do is to talk to the module using the built-in serial port. Have you tried that yet?


Just thought I would loop back on this. I managed to get it working. It was a silly mistake on my behalf, when I read the tutorial for the component over at Sparkfun I didn’t pay attention to the line ending quirk when you switch into command mode. Anyway - all good now.

In the end I didn’t pick up a TTY-USB adapter and instead used the Arduino Serial Monitor and a small sketch to shunt the data backwards and forwards. Thanks for your help!


Good to hear. Yeah, I’ve used an Arduino like that. I posted my sketch on the [OLPC Wiki][1] to help people who can’t get a 3.3V USB serial adapter in difficult to access places.
[1]: “See my sketch.”


Hi guys. Managed to get mine working fine and in the HID profile too but I can’t get it back into SPP mode. Factory reset on GPIO4 isn’t working as I would expect - 3v on at power up, toggled on and off at 1sec intervals - does nothing. Status LED is blinking once per second. Suggestions?


shameless bump. @team any ideas how to get the bluesmirf out of HID profile?


Picked up a TTL Serial USB converter and got it into command mode over that.


Hey Man how did u get it out of the HID mode? I am stuck in HID mode and cant reboot either. Thanks in advance for the help


My issue was getting it into command mode to then get it out of the HID mode. I wasn’t able to do that while sending commands over bluetooth so I picked up a TTL Serial USB converter and that worked for me. Are you sending commands via bluetooth or USB?