Featherwing Prop-Maker Defective


I recently bought a Featherwing Propmaker on the 19th of January and it was working fine until a few days ago. I have it connected to a Feather M4 express and a momentary switch. I am following a guide from Adafruit: https://learn.adafruit.com/lightsaber-featherwing/overview. When I pressed the momentary switch, the board used to run the code properly yet when I try it now, It seems to crash, which is shown by a pulsing yellow light on the Feather M4, and I can’t find anywhere how to fix it. I checked if it was short-circuited with a multimeter and it seemed fine. Any help would be gladly appreciated.



Here is the image for the circuit diagram:

Hi Arya,

Thanks for the information and diagram.

Could you please let us know what error messages if any are appearing.

Your post mentions the code used to work properly but now crashes and that :

which is shown by a pulsing yellow light on the Feather M4

According to this Feather M4 guide:

" pulsing YELLOW : Circuit Python is in safe mode: it crashed and restarted."

Seems like your Feather M4 express may be in safe mode since it’s just pulsing yellow, it might not be that the code has errors, as according to the guide …

Colors with multiple flashes following indicate a Python exception and then indicate the line number of the error. The color of the first flash indicates the type of error:

  • GREEN : IndentationError
  • CYAN : SyntaxError
  • WHITE : NameError
  • ORANGE : OSError
  • PURPLE : ValueError
  • YELLOW : other error

These are followed by flashes indicating the line number, including place value. WHITE flashes are thousands’ place, BLUE are hundreds’ place, YELLOW are tens’ place, and CYAN are one’s place. So for example, an error on line 32 would flash YELLOW three times and then CYAN two times. Zeroes are indicated by an extra-long dark gap.

I recommend checking the Trouble Shooting section in this guide and for the required libraries. https://learn.adafruit.com/lightsaber-featherwing?view=all


I have tried changing the code, wiping the board, changing the version of CircuitPython and my issue has still not been fixed. I have been trying to fix this issue for about 5 months and I haven’t gotten anywhere. I just want my board replaced since nothing I’ve tried has actually worked

Hi Arya,

Thanks for bringing this to our attention and sorry to hear that you are still having trouble with the Featherwing Pro-Maker. We have sent you an email with regards to this issue.