Micro:Bit Advent Calendar Day 06 - 0.96'' OLED Screen with micro:bit


#1

Need help for the Micro:Bit Advent Calendar Day 6 Guide (0.96’’ OLED Screen with micro:bit)? Just post on this thread and our highly trained team of Micro:Bit ninjas will be able to help you in no time!


#2

Worked nicely, thanks guys :slight_smile:


#3

Yes, it worked nicely for me as well. But it took a lot of effort / interpretation / imagination to get some of the steps working.

With all the effort that you have put into this product, I’m guessing that you might want to offer it again next Xmas (but, with the pace of technology, maybe not?) If so, you might want to collect some feedback to help you polish up the product to make it better for next year. Maybe this isn’t the forum for such feedback, but it’s all we have in place at the moment. (And, if this is only a one-off product, feel free to ignore the remainder of this posting.)

I wonder who it is (i.e. what skill level) you are aiming this product at? The earlier steps seemed to be suitable for an innocent, but tech-minded 7-year-old, probably with an interested, but not IT-literate, parent to help. This task suddenly jumped into requiring someone who knew what folders, hex files, unmentioned editors, zip files, etc all were, in following steps 12 and 13.

In fact, if, in Step 9, one copies over all the library files, then you already have the microbit_logo file. You don’t need to try to understand the steps implied by Steps 12 and 13: no LCDAssistant, no cutting and pasting of hex data, no running of a (local) Python program, etc, All you need are the instructions on how to move the supplied logo file into mu_code.

Thanks again

Rob


#4

I agree with @Rob on this. We were going fine up until step 12, and then simply had no idea what to do. Couldn’t finish it.


#5

In an attempt to get something (more than a dot) to appear on the OLED we jumped ahead to step 17 and tried the MakeCode version, which worked successfully.

But now when we try to go back and flash something from Mu it returns the error “Could not enter raw REPL”. I have been able to determine that this relates to something still running in the OLED that Mu cannot stop in order to load the updated code, but I cannot figure out how to make MakeCode “let go” of the OLED so that Mu can take back control.


#6

Well I am completely lost at step 12!! Cannot work out what to do. Got the dot in the middle of the screen, now I’ve stuffed around with it so much it is giving me some error message I can’t read. Anyone have a Step 12 that actually makes sense??

Couldn’t work out how to use the LCD assistant, so I guess we got lost there!


#7

What worked for me (using a laptop running Windows 10) was:

  • Ignore Step 12 totally
  • Instead of Step 13: remember back in Step 9, where you had downloaded the ssd1306library files as a zip, and had moved several .py files from this zip file into the mu_code folder? Now, you look in the same zip file (possibly still in your Downloads folder) and find a sample_images subfolder. In this, you should find a microbit_logo file. Drag this to your mu_code folder.
  • Continue with Step 14…

Or, as Tim Stargoo says, just jump forward to Step 17


#8

Thanks. I thought I tried that last night. But it was getting late and I was getting frazzled. Will try again today, if it doesn’t work I will skip it. Would have been good to be able to follow the instructions though, and know how to put bmp files into it…