‘No Signal’ on HDMI output PI3

Hi All
I have been using my new PI 3+ for about a month. Everything has been fine. I firstly installed Openplotter/NOOB’s software on a new SD card, and everything was fine then suddenly it stopped outputting to my monitor, saying no signal detected, or signal not accepted.
I have tried 3 monitors that have worked before, and 3 HDMI cables. Lucky I have the VNC server installed, and can see on iPad via VNC viewer, and it remembers my wifi etc. So the unit is functioning, but just no HDMI output.
I have tried to change the settings in sudo nano /boot/config.txt as per forums by uncommenting (removing the #, Ctl-X, Y, Sudo reboot

I’ve even tried the HDMI boost setting.

I got the original NOOB’s SD that came with the PI, and installed….nothing worked(as no headless mode setup, so I can’t see whats happening), put in my previous SD card that has Openplotter/Noobs image, and it still boots and can still see on iPad, but not HDMI.

I downloaded the NOOB’s software again and put on new formatted SD card, and installed in PI, and still nothing.

I am presuming that the HDMI port has failed, can anyone offer me anything else to check, or is this a case of sending it back?

And add on to above post, I was trying to connect to Mac last night, and left the PI running, got up this morning and PI outputting to HDMI on monitor, used for 5 minutes, all good, came back after 5 minutes and no HDMI again!!
Any ideas? Faulty HDMI or drivers? Do PI’s have any warranty?
As I use on a yacht for navigation, I can’t have a on/off sometimes works output to HDMI.

Hi Shayne,

There is another similar topic, I’m not sure if any of the comments there are of any relevance to you?

Also are there any errors/changes relevant to hdmi visible with the dmesg command?

Also are there any errors/changes relevant to hdmi visible with the dmesg command?

I second this query.