Pi 4 b won't get power

I have a raspberry Pi 4 Model b, it was running great, everything as normal.

I shut it down as normal, came back a couple hours later and now it won’t boot (doesn’t appear to get power either - No LEDS).

Setup:
No HDMI, I generally SSH into the device.
32gb Sandisk Ultra Micro SD running Raspbian
Was using a New Macbook Air USB-C Charger, but have tried a couple chargers (All 5v 3a).
Nothing Special

Pic:

What are my options?

Hi tiller,

Have you seen this troubleshooting page: https://raspberry.piaustralia.com.au/pages/top-tips-for-troubleshooting-your-raspberry-pi

Yes, if the Raspberry Pi’s PWR LED (red light) doesn’t light up at all, then there’s no power.

Have you also tried using the official Raspberry Pi Power Supply USB-C 5V 15W?

Cheers,
Cherie

I don’t have a official power supply, but I have tried a range of 5v 15W supplies with no success.

I have since done some testing and it boots and works fine if powered by the GPIO pins. So I think the problem is the USB-C port.

Silly Q but have you tried a new USB C cable?

It is probably a smart USB-C Power Supply, and you’re using a Raspberry Pi revision that doesn’t support smart power negotiation.

You should use the Official Raspberry Pi (Australian) Power Supply that doesn’t try to be smart.

No silly questions at the moment, but yes I have. No success.

I have tried other non-smart power supplies (15w - 5v 3a) with no success either.

The macbook charger worked previously and until this problem, was actually the one I used the most.

I have got it running using the the 5v and ground on the GPIO pins which to me suggest the USB-C port on the Pi is broken. Multiple cables and multiple power supplies not working to the port but working with the pins.

EDIT: I am hesitant to buy the official power supply if it’s not going to work (as the usb-c port seems to be the issue)