Pi 4b boot issues

I’ve been having trouble getting a recently purchased pi 4B to boot.
When I power it on, I only see a red power light, nothing from the activity light beyond a split second flash exactly as I plug the USB C in. Any screen that I plug in to either of the hdmi ports does not register any input.
This behavior has not changed throughout anything I try.

Things that I have tried:

  • I am using the official power adapter though I have also tried with a different USB C cable.

  • Using an SD card with the latest version of noobs installer.

  • Flashing Raspbian Buster Lite onto an SD card with Etcher.

  • Tested using 3 different screens to make sure there wasn’t an issue with the screen.

  • Followed the instructions for reprogramming EEPROM from https://www.raspberrypi.org/downloads/

  • I have tried these things with two SD cards freshly formatted before running etcher / copying noobs.

  • I have verified that one of the SD cards I’m using boots fine on a coworkers pi and I see the same behavior when booting from his SD card.

  • If I have the network cable plugged in the pi does not acquire a dhcp lease.

One of the two SD cards I am using is brand new and the other worked on the coworkers pi.

What else I should attempt before assuming the board is faulty?

Thanks for your time

I had same problem. Updated and working card from Pi 3 would do a few green led flashes and go out.

Putting Rasberian (not Noobs) on sdcard worked.

Download full Rasberian from official site as zip file then use Balenda Etcher on windows. It will ask for the zip file detect sd card.

Press flash button. Etcher handles all format and partitioning issues

Be aware that windows will want confirmation so there maybe a small Windows shield that needs clicking before flash button moves to flashing.

1 Like

Thanks James this information has been useful!

Hey, thanks for the reply. Not sure it’s the same issue you had.

The flash I am getting is litterally a split second as power first goes to the board. No further sign of life from the activity light.
I flashed the full Rasbrian on. (Fresh download). No change in behaviour.
(No activity light, no screen output)
Thankyou for the suggestion though.

@ruben mentioned that it might be possible that the SPI EEPROM has become corrupted and has outlined the following fix:


If your Raspberry Pi 4 will not boot, it is possible that the SPI EEPROM has become corrupted.

To check, remove the SD card, disconnect the device from power, then reconnect it. If the green LED does not flash, you will need to reprogram the EEPROM:

  1. Download the bootloader
    SHA-256: 2c5610682edfa2c3a2a41832c687559d8f091b9e48abaeb8577cca2a0cc81839
  2. Extract it to an empty FAT-formatted SD card and insert it into your Raspberry Pi 4
  3. Connect the power and wait for the green LED to flash quickly

As mentioned in the original post that is one of the steps that I have already attempted.

Good news is that after a second email to the customer service team I was able to arrange for a replacement to be shipped out and that worked immediately with the same SD and power supply that I have been testing on.
I will be returning the faulty unit and consider the issue resolved.