Pi 4B - Does not boot

Hi there,

Bought a Pi 4 . It booted fine until last night.

Now it will not provide a signal to HDMI.

The red light is continuous, but the green one has four short flashes and a longer period before repeating.

I tried on different monitor with no difference - don’t think it is booting.

I bought a preformatted SD card.

Looking forward to the help.

I’m having the exact same issue.
I tried the pre-formated sd card in a pi zero and it worked fine. so the problem doesn’t seem to the sd card.

a pi zero and it worked fine

SD Cards are not transferrable between different Pis (different drivers etc for system on chip)

Bought a Pi 4 . It booted fine until last night.

What power supply is being used? What other devices are plugged into the Pi?

The power supply was bought from yourselves.
There is nothing connected apart from a monitor, keyboard and mouse


Has anyone resolved this? I bought the pi 4 kit and it won’t boot.
The sd card works on my pi 3. The pi 4 came with a 5v 2.5a psu although the raspberry pi website recommends a 3a psu? Could this be the issue?

I was sent a new sd card and now all works well

My issue is fixed, pi now running. I followed the recovery instructions in the link below.


If your Raspberry Pi 4 will not boot, it is possible that the SPI EEPROM has become corrupted.

To check, remove the SD card, disconnect the device from power, then reconnect it. If the green LED does not flash, you will need to reprogram the EEPROM:

  1. Download the bootloader
    SHA-256: 2c5610682edfa2c3a2a41832c687559d8f091b9e48abaeb8577cca2a0cc81839
  2. Extract it to an empty FAT-formatted SD card and insert it into your Raspberry Pi 4
  3. Connect the power and wait for the green LED to flash quickly


1 Like

Hi, I am having same issue, Pi4b not booting past 2nd screen(see screenshot). I purchased a 4GB Raspberry pi 4 about a 1 & ½ ago. But I cannot get it to boot anymore?
I have tried installing latest NOOBS and RASPBIAN BUSTER. But cannot get it to work.
I have also installed a fresh image of RASPBIAN BUSTER onto a different 64 gb sandisk card (formatted) and still the issue of not booting.

Please help