Problem rebooting RPi4

Hi guys,

I’ve got a raspberry pi 4 and have been looking into the issues for rebooting it. I’ve checked out: https://www.raspberrypi.org/documentation/hardware/raspberrypi/booteeprom.md
https://www.raspberrypi.org/forums/viewtopic.php?t=58151
The first link seemed to have some useful information for me I ran:
sudo apt update
sudo apt full-upgrade
and then when I checked out
sudo rpi-eeprom-update
it says it is up to date. However when I ran:
sudo reboot
sudo shutdown -r
sudo shutdown now -r
or basically anything that tries to wake the pi when it is halted doesn’t work, such as a button or the pijuice hat SW1. The pi will boot if I remove the power supply and plug it back in. Sometimes I will have a 3v3 voltage across the 3v3 pin and ground. The red LED will always be on and sometimes(rarely) the green LED will turn on and stay on(not flash randomly as if it’s reading the SD card). I do have wake_on_gpio = 1 and power_off_on_halt = 0. I’ve reinstalled the raspi OS and still nothing.
Extra Info:
Using 5.1V 3A official power supply
Using 16gb sd card

Cheers,
Kian