Raspberry Pi Q&A

I am starting this thread to ask general raspberry pi questions, if you have any questions feel free to ask and we will try our hardest to answer in a timely manner with the best information we have on hand

Can i use my older 2.5amp 5volt power supply on the latest raspberry pi 4?
The answer is no the raspberry pi 4 is a little bit more power hungry and requires a minimum power supply specification of 5V DC via USB-C connector (minimum 3Amp).

It should also be noted that the with the introduction of the raspberry pi 4 the power comes in via a USB-C type connector.


We recommend this power supply:

My raspberry pi won’t boot up, i get a black screen what should i do?

The first thing to do is to check all your connections,:

  • With the power disconnected insure that the hdmi cable and mirco-sd card are inserted (HDMI-0, RPI 4)

  • apply power and the pi should boot
    *If the pi doesn’t boot try and using another screen or monitor
    *Alternatively try and reflash your mirco-sd card following this guide

Jaco Jansen has found the content on https://elinux.org/R-Pi_Troubleshooting#Power_.2F_Start-up
useful in resolve a similar issue.

Hi I was wondering can the rpi4 fit into the pi-top3 laptop shell?

Hi Nick,
I am sending you this stream as directed so that you can create a paper trail.

The Raspberry Pi I received 2 weeks ago (Order #2446), I have assembled as per instructions;

  • fan works OK;
  • red light comes on OK;
  • but monitor shows nothing.

I know the monitor line is working because when I transpose another Pi onto it, it works fine.

There is no Green light next to the red light on the Pi board. This may be a good indication of the problem

I spoke with Kevin at Littlebird, and explained all this and he instructed me to send you this email to start up a paper trail so you can send me out a replacement Pi and include return bag for old Pi.

Is this correct?

Many thanks.

Could still actually be a monitor compatibility issue such as Raspberry Pi 4 Model B Showing Blank Screen .

What other monitors have you tried?

have tried all above. 5V 2.5amp power supply. installed updated OS - both from micro SD card and USB. all that comes up on the screen is a colour splash. can you please help?

hi, I’ve used updated sd and usb cards and on my third monitor, it reads underneath 4 red raspberries;

3.5603071 sd 0:0:0:0: [sda] No caching mode page found
3.5604951 sd 0:0:0:0: [sda] Assuming drive cache: write through

any suggestions?

Hey Mark,

Could you please attached a photo with how you connected the Raspberry Pi?



hi Marcus :slightly_smiling_face:
I think I can only add one photo per post so I will post twice … here goes …

I hope this helps.

and here’s the other …

Thanks for this Mark,

Would you be so kind as to show me the underside of the Pi (where the SD card is located)?



Thanks Marcus :slightly_smiling_face: here is the underside with a 32 Gb micro sd card with the latest Raspian OS downloaded and unzipped in it. every time I now turn this Pi on, I get a message “waiting for sd card (settings partition)” with a sliding blue meter going left to right to left etc. Forever.

underneath there is a red raspberry with another option "For recover mode followed by the SHIFT key. whether I press the SHIFT key or not, the above sliding meter keeps sliding and nothing happening. Does all this make sense to you? I hope you’ve seen this before. :slightly_smiling_face:
I’ve tried installing two other Respian downloads, from another 2 sd micro cards and even via the accompanying gold coloured little USB drive, with no success.

I really think it might be easier if I tell you exactly what is happening live - just give me a call on 0417-375-677. Otherwise, this could just be a faulty unit? would you like me to return it?

I have had NO PROBLEM with a previous Pi sent just 2 weeks before.

Best wishes, Mark :slightly_smiling_face: