Raspberry PI4 will not boot

I purchased a Raspberry PI4 4Gb a couple of days ago and I have not been able to get it to boot… initially the complete starter kit I purchased was missing the microSD card that It was meant to include but I tried with one I had lying around I formatted the card installed NOOBS but no dice the red power led stays lit up but the green led flashes twice quickly before staying off I chalked it down to a bad card so I awaited my replacement SD card that turned up yesterday with the same issue occuring. I then tried both cards in a PiZero which booted flawlessly just wondering if there is anything else worth trying or if the unit is faulty I have also re-flashed the bootloader and tried flashing straight raspbian to no effect

What have you tried from: Troubleshooting Raspberry Pi 4 Booting

So far I have tried an additional SD card formatted to FAT32, with both NOOBS and Raspbian installed on them, I have tried:

  • Changing the config so that HDMI hot swap was enabled.
  • Using the Official Power Supply
  • Updated the boot loader which the downloads page on the Raspberry Pi website said could fix boot problems (https://www.raspberrypi.org/downloads/)
  • Have tried both cards in PI Zero that booted without any issues
  • No microSD inserted the pi behaves as it should repeating the 4 green flash error code

Not really sure what else there is to try right now

You’ve mentioned updating the firmware (distinct from the Operating System?), but are you using the latest Raspbian?

Have you swapped the microHDMI ports?

Could you please upload a photo of your setup?

Yes the latest Raspbian which was taken from the downloads page I posted above and I’ve tried both microHDMI ports (0 and 1)

pictured is the PI plugged in with the SD card inserted then with the sd card removed (the 32GB was “included” with the complete starter kit) and the 128GB Samsung EVO is one that I had lying around

I’ve heard reports of the EVO Pluses are known to fail, however the SanDisk Ultra should be fine.

The next thing I’d check is the trying the Pi with an alternate display (using the same cable configuration you’ve shown in the photo).

With difficult displays, I’ve found I had more success when powering on the Pi after connecting the HDMI.

Ok I just tried on a different display with both the hdmi inserted before and after power was supplied with the same issue occurring I’m completely at a loss right now :confused:

Hi again I’ve been trying the same things again now that I’m off my exams hence my lack of posting and I think the unit may be faulty my order number is 144989 or is there anything else I could try?

@ruben mentioned that it might be possible that the SPI EEPROM has become corrupted and has outlined the following fix:


If your Raspberry Pi 4 will not boot, it is possible that the SPI EEPROM has become corrupted.

To check, remove the SD card, disconnect the device from power, then reconnect it. If the green LED does not flash, you will need to reprogram the EEPROM:

  1. Download the bootloader
    SHA-256: 2c5610682edfa2c3a2a41832c687559d8f091b9e48abaeb8577cca2a0cc81839
  2. Extract it to an empty FAT-formatted SD card and insert it into your Raspberry Pi 4
  3. Connect the power and wait for the green LED to flash quickly

Hi thanks again for the reply and your continued assistance, but I tried that and it’s still not working it appeared to flash the EEPROM with the new bootloader but it has not made a difference in booting up

I’ve just sent an email to arrange capturing the Pi for further testing.