Just got my first rPi, cant boot it

So I just got my rpi4b, 4GB. And a 128gb Samsung extreme micro sdhc with noobs. Then I got a micro hdmi cable. Then I got a 3A usb-C power supply.

It won’t boot. If I run it off the 3A usb-c power supply it doesn’t do anything at all(and have tested the cable and psu on my phone, both working). If I run it on less than 3A, e.g. a phone charger, it just shows a red led solid.

I downloaded the noobs files and put them in the root directory of my fat32 formatted 128gb sdhc

All the files are in the root of the sdhc card directory

Have you tried a smaller SD card, eg. a 8 or 16 gb card?

Just got my 1st rPI3 in a media kit which I have been wanting for ages.
Also bought the 7" touch screen to go with it. The kit comes with sdcard and the power supply so one would assume it would all plug & play - unfortunately very disappointed - all I can see are rolling lines on the display. Checked the display with my laptop - perfect. Shall I take the kit back to Jaycar and get a refund ?